CVE-2021-37149

NameCVE-2021-37149
DescriptionImproper Input Validation vulnerability in header parsing of Apache Traffic Server allows an attacker to smuggle requests. This issue affects Apache Traffic Server 8.0.0 to 8.1.2 and 9.0.0 to 9.1.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5153-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)buster, buster (security)8.0.2+ds-1+deb10u6fixed
bullseye (security), bullseye8.1.5+ds-1~deb11u1fixed
bookworm, sid9.1.3+ds-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversourcebuster8.0.2+ds-1+deb10u6DSA-5153-1
trafficserversourcebullseye8.1.1+ds-1.1+deb11u1DSA-5153-1
trafficserversource(unstable)9.1.1+ds-1

Notes

https://www.openwall.com/lists/oss-security/2021/11/02/11
https://github.com/apache/trafficserver/pull/8458/
https://github.com/apache/trafficserver/commit/2addc8ca71449ceac0d5b80172460ee09c938f5e (8.1.x)
https://github.com/apache/trafficserver/commit/83c89f3d217d473ecb000b68c910c0f183c3a355 (master)

Search for package or bug name: Reporting problems