CVE-2021-37155

NameCVE-2021-37155
DescriptionwolfSSL 4.6.x through 4.7.x before 4.8.0 does not produce a failure outcome when the serial number in an OCSP request differs from the serial number in the OCSP response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs991443

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wolfssl (PTS)bookworm, bullseye, sid4.6.0-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wolfsslsource(unstable)(unfixed)991443

Notes

[bullseye] - wolfssl <no-dsa> (Minor issue)
https://github.com/wolfSSL/wolfssl/pull/3990
https://github.com/wolfSSL/wolfssl/releases/tag/v4.8.0-stable

Search for package or bug name: Reporting problems