CVE-2021-37220

NameCVE-2021-37220
DescriptionMuPDF through 1.18.1 has an out-of-bounds write because the cached col ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs991402

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mupdf (PTS)stretch1.9a+ds1-4+deb9u4fixed
stretch (security)1.14.0+ds1-4+deb9u1fixed
buster1.14.0+ds1-4+deb10u3vulnerable
buster (security)1.14.0+ds1-4+deb10u2vulnerable
bullseye1.17.0+ds1-2fixed
bullseye (security)1.17.0+ds1-1.3~deb11u1vulnerable
bookworm, sid1.19.0+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mupdfsourcestretch(not affected)
mupdfsource(unstable)1.17.0+ds1-2991402

Notes

[buster] - mupdf <no-dsa> (Minor issue; can be fixed via point release)
[stretch] - mupdf <not-affected> (Vulnerable code not present)
http://git.ghostscript.com/?p=mupdf.git;h=f5712c9949d026e4b891b25837edd2edc166151f
https://bugs.ghostscript.com/show_bug.cgi?id=703791
On Stretch, an earlier version of the code exits early instead of crashing.

Search for package or bug name: Reporting problems