CVE-2021-3731

NameCVE-2021-3731
DescriptionLedgerSMB does not sufficiently guard against being wrapped by other sites, making it vulnerable to 'clickjacking'. This allows an attacker to trick a targetted user to execute unintended actions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4962-1
NVD severitymedium
Debian Bugs992817

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ledgersmb (PTS)buster1.6.9+ds-1vulnerable
buster (security)1.6.9+ds-1+deb10u3fixed
bullseye1.6.9+ds-2vulnerable
bullseye (security)1.6.9+ds-2+deb11u3fixed
bookworm, sid1.6.9+ds-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ledgersmbsourcebuster1.6.9+ds-1+deb10u2DSA-4962-1
ledgersmbsourcebullseye1.6.9+ds-2+deb11u2DSA-4962-1
ledgersmbsource(unstable)1.6.9+ds-2.1992817

Notes

https://ledgersmb.org/cve-2021-3731-clickjacking

Search for package or bug name: Reporting problems