CVE-2021-37519

NameCVE-2021-37519
DescriptionBuffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
memcached (PTS)buster1.5.6-1.1fixed
buster (security)1.5.6-1.1+deb10u1fixed
bullseye1.6.9+dfsg-1vulnerable
bookworm1.6.18-1fixed
sid, trixie1.6.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
memcachedsourcebuster(not affected)
memcachedsource(unstable)1.6.10+dfsg-1

Notes

[bullseye] - memcached <no-dsa> (Minor issue)
[buster] - memcached <not-affected> (Vulnerable code not present)
https://github.com/memcached/memcached/issues/805
https://github.com/memcached/memcached/commit/ddee3e27a031be22f5f28c160be18fd3cb9bc63d (1.6.10)

Search for package or bug name: Reporting problems