CVE-2021-37530

NameCVE-2021-37530
DescriptionA denial of service vulnerabiity exists in fig2dev through 3.28a due to a segfault in the open_stream function in readpics.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fig2dev (PTS)buster1:3.2.7a-5+deb10u4vulnerable
bullseye1:3.2.8-3vulnerable
bookworm, sid1:3.2.8b-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fig2devsource(unstable)1:3.2.8b-1
transfigsource(unstable)(unfixed)

Notes

[bullseye] - fig2dev <no-dsa> (Minor issue)
[buster] - fig2dev <no-dsa> (Minor issue)
[stretch] - fig2dev <no-dsa> (Minor issue)
https://sourceforge.net/p/mcj/tickets/126/
https://sourceforge.net/p/mcj/fig2dev/ci/ff103511e49c44c83fc58e2092aa37e9019a3a9f/

Search for package or bug name: Reporting problems