CVE-2021-3756

NameCVE-2021-3756
Descriptionlibmysofa is vulnerable to Heap-based Buffer Overflow
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmysofa (PTS)buster0.6~dfsg0-3+deb10u1vulnerable
bullseye1.2~dfsg0-1vulnerable
bookworm, sid1.2.1~dfsg0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmysofasource(unstable)1.2.1~dfsg0-1

Notes

[bullseye] - libmysofa <no-dsa> (Minor issue)
[buster] - libmysofa <no-dsa> (Minor issue)
https://huntr.dev/bounties/7ca8d9ea-e2a6-4294-af28-70260bb53bc1/
https://github.com/hoene/libmysofa/commit/890400ebd092c574707d0c132124f8ff047e20e1 (v1.2.1)

Search for package or bug name: Reporting problems