CVE-2021-37600

NameCVE-2021-37600
DescriptionAn integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. NOTE: this is unexploitable in GNU C Library environments, and possibly in all realistic environments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3782-1
Debian Bugs991619

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)buster2.33.1-0.1vulnerable
buster (security)2.33.1-0.1+deb10u1fixed
bullseye2.36.1-8+deb11u1fixed
bullseye (security)2.36.1-8+deb11u2fixed
bookworm2.38.1-5fixed
bookworm (security)2.38.1-5+deb12u1fixed
sid, trixie2.40.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsourcebuster2.33.1-0.1+deb10u1DLA-3782-1
util-linuxsource(unstable)2.36.1-8low991619

Notes

[stretch] - util-linux <no-dsa> (Minor issue)
https://github.com/karelzak/util-linux/issues/1395
https://github.com/karelzak/util-linux/commit/1c9143d0c1f979c3daf10e1c37b5b1e916c22a1c

Search for package or bug name: Reporting problems