CVE-2021-37601

NameCVE-2021-37601
Descriptionmuc.lib.lua in Prosody 0.11.0 through 0.11.9 allows remote attackers to obtain sensitive information (list of admins, members, owners, and banned entities of a Multi-User chat room) in some common configurations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)stretch0.9.12-2+deb9u2fixed
stretch (security)0.9.12-2+deb9u4fixed
buster, buster (security)0.11.2-1+deb10u2vulnerable
bullseye0.11.9-2fixed
bookworm, sid0.11.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysourcestretch(not affected)
prosodysource(unstable)0.11.9-2

Notes

[buster] - prosody <no-dsa> (Minor issue)
[stretch] - prosody <not-affected> (Vulnerable code not present)
https://prosody.im/security/advisory_20210722/

Search for package or bug name: Reporting problems