CVE-2021-37620

NameCVE-2021-37620
DescriptionExiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.4 and earlier. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)buster0.25-4+deb10u2vulnerable
buster (security)0.25-4+deb10u3vulnerable
bullseye (security), bullseye0.27.3-3+deb11u1vulnerable
bookworm, sid0.27.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)0.27.5-1

Notes

[bullseye] - exiv2 <ignored> (Minor issue)
[buster] - exiv2 <ignored> (Minor issue)
[stretch] - exiv2 <ignored> (Minor issue)
https://github.com/Exiv2/exiv2/security/advisories/GHSA-v5g7-46xf-h728
https://github.com/Exiv2/exiv2/pull/1769

Search for package or bug name: Reporting problems