CVE-2021-3803

NameCVE-2021-3803
Descriptionnth-check is vulnerable to Inefficient Regular Expression Complexity
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3428-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-nth-check (PTS)buster1.0.1-1vulnerable
buster (security)1.0.1-1+deb10u1fixed
bullseye2.0.0-1+deb11u1fixed
bookworm2.0.1-2fixed
trixie, sid2.1.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-nth-checksourcestretch(unfixed)end-of-life
node-nth-checksourcebuster1.0.1-1+deb10u1DLA-3428-1
node-nth-checksourcebullseye2.0.0-1+deb11u1
node-nth-checksource(unstable)2.0.1-1

Notes

[stretch] - node-nth-check <end-of-life> (Nodejs in stretch not covered by security support)
https://github.com/fb55/nth-check/commit/9894c1d2010870c351f66c6f6efcf656e26bb726 (v2.0.1)
https://huntr.dev/bounties/8cf8cc06-d2cf-4b4e-b42c-99fafb0b04d0/
https://github.com/advisories/GHSA-rp65-9cf3-cjxr

Search for package or bug name: Reporting problems