CVE-2021-38084

NameCVE-2021-38084
DescriptionAn issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs989375

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
courier (PTS)stretch0.76.3-5+deb9u1vulnerable
buster1.0.6-1vulnerable
bookworm, bullseye, sid1.0.16-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
couriersource(unstable)(unfixed)989375

Notes

[bullseye] - courier <no-dsa> (Minor issue)
[buster] - courier <no-dsa> (Minor issue)
[stretch] - courier <postponed> (Minor issue, include in next update)
https://sourceforge.net/p/courier/mailman/courier-imap/thread/cone.1382574216.483027.8082.1000%40monster.email-scan.com/#msg31555583
https://sourceforge.net/p/courier/mailman/message/37329216/
https://sourceforge.net/p/courier/courier-libs.git/ci/97ed62b17a2616c758d09105b5a14dd1038cff6f/ (1.1.5)

Search for package or bug name: Reporting problems