CVE-2021-38115

NameCVE-2021-38115
Descriptionread_header_tga in gd_tga.c in the GD Graphics Library (aka LibGD) through 2.3.2 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991912

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)stretch2.2.4-2+deb9u5vulnerable
stretch (security)2.2.4-2+deb9u4vulnerable
buster2.2.5-5.2vulnerable
bookworm, sid, bullseye2.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)(unfixed)991912

Notes

[bullseye] - libgd2 <no-dsa> (Minor issue)
[buster] - libgd2 <no-dsa> (Minor issue)
[stretch] - libgd2 <no-dsa> (Minor issue)
https://github.com/libgd/libgd/issues/697
https://github.com/libgd/libgd/commit/8b111b2b4a4842179be66db68d84dda91a246032

Search for package or bug name: Reporting problems