CVE-2021-38385

NameCVE-2021-38385
DescriptionTor before 0.3.5.16, 0.4.5.10, and 0.4.6.7 mishandles the relationship between batch-signature verification and single-signature verification, leading to a remote assertion failure, aka TROVE-2021-007.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4961-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)stretch0.2.9.16-1vulnerable
stretch (security)0.2.9.15-1vulnerable
buster0.3.5.14-1vulnerable
buster (security)0.3.5.16-1fixed
bullseye0.4.5.9-1vulnerable
bullseye (security)0.4.5.10-1~deb11u1fixed
bookworm, sid0.4.5.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsourcestretch(unfixed)end-of-life
torsourcebuster0.3.5.16-1DSA-4961-1
torsourcebullseye0.4.5.10-1~deb11u1DSA-4961-1
torsource(unstable)0.4.5.10-1

Notes

[stretch] - tor <end-of-life> (See DSA 4644)
https://blog.torproject.org/node/2062
https://bugs.torproject.org/tpo/core/tor/40078

Search for package or bug name: Reporting problems