CVE-2021-38508

NameCVE-2021-38508
DescriptionBy displaying a form validity message in the correct location at the same time as a permission prompt (such as for geolocation), the validity message could have obscured the prompt, resulting in the user potentially being tricked into granting the permission. This vulnerability affects Firefox < 94, Thunderbird < 91.3, and Firefox ESR < 91.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2863-1, DLA-2874-1, DSA-5026-1, DSA-5034-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid100.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1vulnerable
stretch (security)91.9.0esr-1~deb9u1fixed
buster78.14.0esr-1~deb10u1vulnerable
buster (security)91.9.0esr-1~deb10u1fixed
bullseye78.15.0esr-1~deb11u1vulnerable
bullseye (security)91.9.0esr-1~deb11u1fixed
bookworm, sid91.9.0esr-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1vulnerable
stretch (security)1:91.8.0-1~deb9u1fixed
buster1:78.14.0-1~deb10u1vulnerable
buster (security)1:91.8.0-1~deb10u1fixed
bullseye1:78.14.0-1~deb11u1vulnerable
bullseye (security)1:91.8.0-1~deb11u1fixed
bookworm1:91.8.1-1fixed
sid1:91.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)94.0-1
firefox-esrsourcestretch91.4.1esr-1~deb9u1DLA-2863-1
firefox-esrsourcebullseye91.4.1esr-1~deb11u1DSA-5026-1
firefox-esrsource(unstable)91.3.0esr-1
thunderbirdsourcestretch1:91.4.1-1~deb9u1DLA-2874-1
thunderbirdsourcebuster1:91.4.1-1~deb10u1DSA-5034-1
thunderbirdsourcebullseye1:91.4.1-1~deb11u1DSA-5034-1
thunderbirdsource(unstable)1:91.3.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2021-48/#CVE-2021-38508
https://www.mozilla.org/en-US/security/advisories/mfsa2021-49/#CVE-2021-38508
https://www.mozilla.org/en-US/security/advisories/mfsa2021-50/#CVE-2021-38508

Search for package or bug name: Reporting problems