CVE-2021-38711

NameCVE-2021-38711
DescriptionIn gitit before 0.15.0.0, the Export feature can be exploited to leak information from files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs992297

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gitit (PTS)stretch0.12.1.1+dfsg-6vulnerable
buster0.12.3.1+dfsg-1vulnerable
bookworm, sid, bullseye0.13.0.0+dfsg-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gititsource(unstable)(unfixed)992297

Notes

[bullseye] - gitit <no-dsa> (Minor issue)
[buster] - gitit <no-dsa> (Minor issue)
[stretch] - gitit <no-dsa> (Minor issue)
https://github.com/jgm/gitit/commit/eed32638f4f6e3b2f4b8a9a04c4b72001acf9ad8

Search for package or bug name: Reporting problems