CVE-2021-3875

NameCVE-2021-3875
Descriptionvim is vulnerable to Heap-based Buffer Overflow
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs996593

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch2:8.0.0197-4+deb9u3fixed
stretch (security)2:8.0.0197-4+deb9u4fixed
buster2:8.1.0875-5fixed
bullseye2:8.2.2434-3+deb11u1fixed
bookworm, sid2:8.2.3995-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcestretch(not affected)
vimsourcebuster(not affected)
vimsourcebullseye(not affected)
vimsource(unstable)2:8.2.3565-1996593

Notes

[bullseye] - vim <not-affected> (Vulnerable feature and code introduced later)
[buster] - vim <not-affected> (Vulnerable feature and code introduced later)
[stretch] - vim <not-affected> (Vulnerable feature and code introduced later)
https://huntr.dev/bounties/5cdbc168-6ba1-4bc2-ba6c-28be12166a53/
Search from cursor position introduced in: https://github.com/vim/vim/commit/04db26b36000a4677b95403ec94bd11f6cc73975 (v8.2.3110)
Fixed by: https://github.com/vim/vim/commit/35a319b77f897744eec1155b736e9372c9c5575f (v8.2.3489)

Search for package or bug name: Reporting problems