CVE-2021-3912

NameCVE-2021-3912
DescriptionOctoRPKI tries to load the entire contents of a repository in memory, and in the case of a GZIP bomb, unzip it in memory, making it possible to create a repository that makes OctoRPKI run out of memory (and thus crash).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5041-1
NVD severitymedium
Debian Bugs929024

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cfrpki (PTS)bullseye1.2.2-1vulnerable
bullseye (security)1.4.2-1~deb11u1fixed
bookworm, sid1.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cfrpkisourcebullseye1.4.2-1~deb11u1DSA-5041-1
cfrpkisource(unstable)1.4.0-1
routinatorITP929024

Notes

https://github.com/cloudflare/cfrpki/security/advisories/GHSA-g9wh-3vrx-r7hg

Search for package or bug name: Reporting problems