CVE-2021-39150

NameCVE-2021-39150
DescriptionXStream is a simple library to serialize objects to XML and back again. In affected versions this vulnerability may allow a remote attacker to request data from internal resources that are not publicly available only by manipulating the processed input stream with a Java runtime version 14 to 8. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the [Security Framework](https://x-stream.github.io/security.html#framework), you will have to use at least version 1.4.18.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxstream-java (PTS)stretch1.4.9-2vulnerable
stretch (security)1.4.11.1-1+deb9u3vulnerable
buster, buster (security)1.4.11.1-1+deb10u2vulnerable
bullseye1.4.15-3vulnerable
bookworm, sid1.4.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxstream-javasource(unstable)1.4.18-1

Notes

https://github.com/x-stream/xstream/security/advisories/GHSA-cxfm-5m4g-x7xp
https://x-stream.github.io/CVE-2021-39150.html

Search for package or bug name: Reporting problems