CVE-2021-3918

NameCVE-2021-3918
Descriptionjson-schema is vulnerable to Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution')
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs999765

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-json-schema (PTS)buster0.2.3-1vulnerable
bullseye0.3.0+~7.0.6-1vulnerable
bookworm, sid0.4.0+~7.0.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-json-schemasource(unstable)0.4.0+~7.0.9-1999765

Notes

[bullseye] - node-json-schema <no-dsa> (Minor issue)
[buster] - node-json-schema <no-dsa> (Minor issue)
https://github.com/kriszyp/json-schema/commit/22f146111f541d9737e832823699ad3528ca7741 (v0.4.0)

Search for package or bug name: Reporting problems