CVE-2021-39242

NameCVE-2021-39242
DescriptionAn issue was discovered in HAProxy 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. It can lead to a situation with an attacker-controlled HTTP Host header, because a mismatch between Host and authority is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4960-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
haproxy (PTS)stretch1.7.5-2fixed
buster1.8.19-1+deb10u3fixed
buster (security)1.8.19-1+deb10u2fixed
bullseye2.2.9-2vulnerable
bullseye (security)2.2.9-2+deb11u2fixed
bookworm2.2.16-2fixed
sid2.2.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
haproxysourcestretch(not affected)
haproxysourcebuster(not affected)
haproxysourcebullseye2.2.9-2+deb11u1DSA-4960-1
haproxysource(unstable)2.2.16-1

Notes

[buster] - haproxy <not-affected> (Vulnerable code introduced later)
[stretch] - haproxy <not-affected> (Vulnerable code introduced later)
https://www.mail-archive.com/haproxy@formilux.org/msg41041.html
https://git.haproxy.org/?p=haproxy.git;a=commit;h=b5d2b9e154d78e4075db163826c5e0f6d31b2ab1

Search for package or bug name: Reporting problems