CVE-2021-3927

NameCVE-2021-3927
Descriptionvim is vulnerable to Heap-based Buffer Overflow
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch (security), stretch2:8.0.0197-4+deb9u3vulnerable
buster2:8.1.0875-5vulnerable
bullseye2:8.2.2434-3vulnerable
bookworm, sid2:8.2.3565-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)(unfixed)

Notes

[stretch] - vim <no-dsa> (Minor issue)
https://huntr.dev/bounties/9c2b2c82-48bb-4be9-ab8f-a48ea252d1b0
Fixed by: https://github.com/vim/vim/commit/0b5b06cb4777d1401fdf83e7d48d287662236e7e (v8.2.3581)

Search for package or bug name: Reporting problems