CVE-2021-39537

NameCVE-2021-39537
DescriptionAn issue was discovered in ncurses through v6.2-1. _nc_captoinfo in captoinfo.c has a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ncurses (PTS)stretch6.0+20161126-1+deb9u2vulnerable
buster6.1+20181013-2+deb10u2vulnerable
bullseye6.2+20201114-2vulnerable
bookworm6.2+20201114-4vulnerable
sid6.2+20210905-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ncursessource(unstable)(unfixed)unimportant

Notes

https://lists.gnu.org/archive/html/bug-ncurses/2020-08/msg00006.html
Negligible security impact

Search for package or bug name: Reporting problems