CVE-2021-3996

NameCVE-2021-3996
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5055-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)stretch (security), stretch2.29.2-1+deb9u1fixed
buster2.33.1-0.1fixed
bullseye (security), bullseye2.36.1-8+deb11u1fixed
bookworm, sid2.38-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsourcestretch(not affected)
util-linuxsourcebuster(not affected)
util-linuxsourcebullseye2.36.1-8+deb11u1DSA-5055-1
util-linuxsource(unstable)2.37.3-1

Notes

[buster] - util-linux <not-affected> (Vulnerable code introduced later)
[stretch] - util-linux <not-affected> (Vulnerable code introduced later)
Introduced by: https://github.com/util-linux/util-linux/commit/5fea669e9ef0a08804f72bb40f859f239f68c30a (v2.34-rc1)
Fixed by: https://github.com/util-linux/util-linux/commit/018a10907fa9885093f6d87401556932c2d8bd2b (v2.37.3)
https://mirrors.edge.kernel.org/pub/linux/utils/util-linux/v2.37/v2.37.3-ReleaseNotes
https://www.openwall.com/lists/oss-security/2022/01/24/2

Search for package or bug name: Reporting problems