CVE-2021-40083

NameCVE-2021-40083
DescriptionKnot Resolver before 5.3.2 is prone to an assertion failure, triggerable by a remote attacker in an edge case (NSEC3 with too many iterations used for a positive wildcard proof).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991463

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
knot-resolver (PTS)buster3.2.1-3fixed
bullseye5.3.1-1vulnerable
bookworm, sid5.4.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
knot-resolversourceexperimental5.4.1-1
knot-resolversourcebuster(not affected)
knot-resolversource(unstable)5.4.1-2991463

Notes

[bullseye] - knot-resolver <no-dsa> (Minor issue; can be fixed via point release)
[buster] - knot-resolver <not-affected> (Vulnerable code introduced later)
https://gitlab.nic.cz/knot/knot-resolver/-/merge_requests/1169
Introduced by https://gitlab.nic.cz/knot/knot-resolver/-/commit/7107faebc72c14c864622128a20a9b39fe94d733 (5.3.1)

Search for package or bug name: Reporting problems