CVE-2021-40516

NameCVE-2021-40516
DescriptionWeeChat before 3.2.1 allows remote attackers to cause a denial of service (crash) via a crafted WebSocket frame that trigger an out-of-bounds read in plugins/relay/relay-websocket.c in the Relay plugin.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2770-1
Debian Bugs993803

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weechat (PTS)stretch1.6-1+deb9u2vulnerable
stretch (security)1.6-1+deb9u3fixed
buster2.3-1+deb10u1fixed
bullseye3.0-1+deb11u1fixed
bookworm, sid3.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weechatsourcestretch1.6-1+deb9u3DLA-2770-1
weechatsourcebuster2.3-1+deb10u1
weechatsourcebullseye3.0-1+deb11u1
weechatsource(unstable)3.2.1-1993803

Notes

https://github.com/weechat/weechat/commit/8b1331f98de1714bae15a9ca2e2b393ba49d735b

Search for package or bug name: Reporting problems