CVE-2021-40528

NameCVE-2021-40528
DescriptionThe ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt20 (PTS)stretch1.7.6-2+deb9u3vulnerable
stretch (security)1.7.6-2+deb9u4vulnerable
buster1.8.4-5+deb10u1vulnerable
bullseye1.8.7-6vulnerable
bookworm, sid1.9.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgcrypt20source(unstable)1.9.4-2

Notes

[bullseye] - libgcrypt20 <no-dsa> (Minor issue)
[buster] - libgcrypt20 <no-dsa> (Minor issue)
[stretch] - libgcrypt20 <no-dsa> (Minor issue)
https://eprint.iacr.org/2021/923
https://ibm.github.io/system-security-research-updates/2021/07/20/insecurity-elgamal-pt1
https://ibm.github.io/system-security-research-updates/2021/09/06/insecurity-elgamal-pt2
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=e8b7f10be275bcedb5fc05ed4837a89bfd605c61 (1.9.x)
Related to CVE-2021-33560, but not a duplicate. Unfortunately scope of CVE-2021-33560 and
CVE-2021-40528 got switched at some point, and CVE-2021-33560 referring to the blinding
hardening. We keep the original association as per 2021-09-19 (until MITRE clarifies on
a query).

Search for package or bug name: Reporting problems