DescriptionThe ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt20 (PTS)stretch1.7.6-2+deb9u3vulnerable
stretch (security)1.7.6-2+deb9u4vulnerable
bookworm, sid1.9.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - libgcrypt20 <no-dsa> (Minor issue)
[buster] - libgcrypt20 <no-dsa> (Minor issue)
[stretch] - libgcrypt20 <no-dsa> (Minor issue);a=commit;h=e8b7f10be275bcedb5fc05ed4837a89bfd605c61 (1.9.x)
Related to CVE-2021-33560, but not a duplicate. Unfortunately scope of CVE-2021-33560 and
CVE-2021-40528 got switched at some point, and CVE-2021-33560 referring to the blinding
hardening. We keep the original association as per 2021-09-19 (until MITRE clarifies on
a query).

Search for package or bug name: Reporting problems