CVE-2021-40647

NameCVE-2021-40647
DescriptionIn man2html 1.6g, a specific string being read in from a file will overwrite the size parameter in the top chunk of the heap. This at least causes the program to segmentation abort if the heap size parameter isn't aligned correctly. In version before GLIBC version 2.29 and aligned correctly, it allows arbitrary write anywhere in the programs memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
man2html (PTS)buster1.6g-11vulnerable
bookworm, sid, bullseye1.6g-14vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
man2htmlsource(unstable)(unfixed)

Notes

[bullseye] - man2html <no-dsa> (Minor issue)
https://gist.github.com/untaman/cb58123fe89fc65e3984165db5d40933

Search for package or bug name: Reporting problems