CVE-2021-4070

NameCVE-2021-4070
DescriptionOff-by-one Error in GitHub repository v2fly/v2ray-core prior to 4.44.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs1010377

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-v2ray-core (PTS)bullseye4.34.0-1vulnerable
bookworm, sid4.34.0-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-v2ray-coresource(unstable)(unfixed)1010377

Notes

https://huntr.dev/bounties/8da19456-4d89-41ef-9781-a41efd6a1877/
https://github.com/v2fly/v2ray-core/commit/c1af2bfd7aa59a4482aa7f6ec4b9208c1d350b5c

Search for package or bug name: Reporting problems