CVE-2021-40818

NameCVE-2021-40818
Descriptionscheme/webauthn.c in Glewlwyd SSO server through 2.5.3 has a buffer overflow during FIDO2 signature validation in webauthn registration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs993867

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glewlwyd (PTS)buster1.4.9-1vulnerable
bullseye2.5.2-2vulnerable
bookworm, sid2.5.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glewlwydsource(unstable)2.5.2-3993867

Notes

https://github.com/babelouest/glewlwyd/commit/0efd112bb62f566877750ad62ee828bff579b4e2

Search for package or bug name: Reporting problems