CVE-2021-41055

NameCVE-2021-41055
DescriptionGajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5064-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-nbxmpp (PTS)stretch0.5.4-1fixed
buster0.6.10-1fixed
bullseye (security), bullseye2.0.2-1+deb11u1fixed
bookworm2.0.6-1fixed
sid3.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-nbxmppsourcestretch(not affected)
python-nbxmppsourcebuster(not affected)
python-nbxmppsourcebullseye2.0.2-1+deb11u1DSA-5064-1
python-nbxmppsource(unstable)2.0.4-1

Notes

[buster] - python-nbxmpp <not-affected> (Vulnerable code not present)
[stretch] - python-nbxmpp <not-affected> (Vulnerable code introduced later (modules added in v1.0.0))
https://dev.gajim.org/gajim/gajim/-/issues/10638
https://dev.gajim.org/gajim/python-nbxmpp/-/commit/8a626829d7c4b14077f764e61b1d1e867d21413f
Fix in python-nbxmpp, and gajim 1.3.3 bumps depends on required nbxmpp version.

Search for package or bug name: Reporting problems