CVE-2021-4110

NameCVE-2021-4110
Descriptionmruby is vulnerable to NULL Pointer Dereference
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1001768

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mruby (PTS)stretch1.2.0+20161228+git30d5424a-1vulnerable
stretch (security)1.2.0+20161228+git30d5424a-1+deb9u1vulnerable
buster2.0.0-1vulnerable
bullseye2.1.2-3vulnerable
bookworm, sid3.0.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mrubysource(unstable)3.0.0-21001768

Notes

[bullseye] - mruby <no-dsa> (Minor issue)
[buster] - mruby <no-dsa> (Minor issue)
[stretch] - mruby <postponed> (revisit when/if fix is complete)
https://huntr.dev/bounties/4ce5dc47-2512-4c87-8609-453adc8cad20
https://github.com/mruby/mruby/commit/f5e10c5a79a17939af763b1dcf5232ce47e24a34

Search for package or bug name: Reporting problems