CVE-2021-41164

NameCVE-2021-41164
DescriptionCKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs999909

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)stretch4.5.7+dfsg-2vulnerable
stretch (security)4.5.7+dfsg-2+deb9u1vulnerable
buster4.11.1+dfsg-1vulnerable
bullseye4.16.0+dfsg-2vulnerable
bookworm, sid4.16.2+dfsg-1vulnerable
ckeditor3 (PTS)stretch3.6.6.1+dfsg-1fixed
buster3.6.6.1+dfsg-3fixed
bookworm, sid, bullseye3.6.6.1+dfsg-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsource(unstable)(unfixed)999909
ckeditor3source(unstable)(not affected)

Notes

[bullseye] - ckeditor <no-dsa> (Minor issue)
[buster] - ckeditor <no-dsa> (Minor issue)
[stretch] - ckeditor <no-dsa> (Minor issue)
- ckeditor3 <not-affected> (Advanced Content Filter introduced in v4.1)
https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-pvmx-g8h5-cprj (v4.17.0)

Search for package or bug name: Reporting problems