CVE-2021-4156

NameCVE-2021-4156
DescriptionAn out-of-bounds read flaw was found in libsndfile's FLAC codec functionality. An attacker who is able to submit a specially crafted file (via tricking a user to open or otherwise) to an application linked with libsndfile and using the FLAC codec, could trigger an out-of-bounds read that would most likely cause a crash but could potentially leak memory information that could be used in further exploitation of other flaws.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3058-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)stretch1.0.27-3vulnerable
stretch (security)1.0.27-3+deb9u3fixed
buster, buster (security)1.0.28-6+deb10u1vulnerable
bookworm, sid, bullseye1.0.31-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesourcestretch1.0.27-3+deb9u3DLA-3058-1
libsndfilesource(unstable)(unfixed)

Notes

[bullseye] - libsndfile <no-dsa> (Minor issue)
[buster] - libsndfile <no-dsa> (Minor issue)
https://github.com/libsndfile/libsndfile/issues/731
https://github.com/libsndfile/libsndfile/commit/ced91d7b971be6173b604154c39279ce90ad87cc (1.1.0beta1)

Search for package or bug name: Reporting problems