CVE-2021-41585

NameCVE-2021-41585
DescriptionImproper Input Validation vulnerability in accepting socket connections in Apache Traffic Server allows an attacker to make the server stop accepting new connections. This issue affects Apache Traffic Server 5.0.0 to 9.1.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)buster, buster (security)8.0.2+ds-1+deb10u5fixed
bullseye8.1.1+ds-1.1fixed
bookworm9.1.2+ds-1fixed
sid9.1.2+ds-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversource(unstable)(not affected)

Notes

- trafficserver <not-affected> (Only affects FreeBSD)
https://www.openwall.com/lists/oss-security/2021/11/02/11
https://github.com/apache/trafficserver/pull/8456/
https://github.com/apache/trafficserver/commit/268b540edae0b3e51d033795a4dd7404a5756a93 (master)
https://github.com/apache/trafficserver/commit/2b078741ecf14cbc7f5773b3e14ef0c1d3cf4cfb (8.1.x)

Search for package or bug name: Reporting problems