CVE-2021-41617

NameCVE-2021-41617
Descriptionsshd in OpenSSH 6.2 through 8.x before 8.8, when certain non-default configurations are used, allows privilege escalation because supplemental groups are not initialized as expected. Helper programs for AuthorizedKeysCommand and AuthorizedPrincipalsCommand may run with privileges associated with group memberships of the sshd process, if the configuration specifies running the command as a different user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs995130

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)stretch1:7.4p1-10+deb9u7vulnerable
stretch (security)1:7.4p1-10+deb9u6vulnerable
buster1:7.9p1-10+deb10u2vulnerable
buster (security)1:7.9p1-10+deb10u1vulnerable
bullseye1:8.4p1-5vulnerable
bookworm, sid1:8.4p1-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)(unfixed)995130

Notes

[bullseye] - openssh <no-dsa> (Minor issue)
[buster] - openssh <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2021/09/26/1
https://github.com/openssh/openssh-portable/commit/f3cbe43e28fe71427d41cfe3a17125b972710455
https://github.com/openssh/openssh-portable/commit/bf944e3794eff5413f2df1ef37cddf96918c6bde

Search for package or bug name: Reporting problems