CVE-2021-41801

NameCVE-2021-41801
DescriptionThe ReplaceText extension through 1.41 for MediaWiki has Incorrect Access Control. When a user is blocked after submitting a replace job, the job is still run, even if it may be run at a later time (due to the job queue backlog)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4979-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2fixed
buster (security)1:1.31.16-1+deb10u4fixed
bullseye1:1.35.4-1+deb11u2fixed
bullseye (security)1:1.35.8-1~deb11u1fixed
bookworm1:1.35.8-1.1fixed
sid1:1.39.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch(not affected)
mediawikisourcebuster1:1.31.16-1~deb10u1DSA-4979-1
mediawikisourcebullseye1:1.35.4-1~deb11u1DSA-4979-1
mediawikisource(unstable)1:1.35.4-1

Notes

[stretch] - mediawiki <not-affected> (The vulnerable code was introduced later)
https://lists.wikimedia.org/hyperkitty/list/wikitech-l@lists.wikimedia.org/thread/2IFS5CM2YV4VMSODPX3J2LFHKSEWVFV5/
https://phabricator.wikimedia.org/T279090

Search for package or bug name: Reporting problems