CVE-2021-41819

NameCVE-2021-41819
DescriptionCGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2853-1, DSA-5066-1, DSA-5067-1
Debian Bugs1002995

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby2.3 (PTS)stretch2.3.3-1+deb9u8vulnerable
stretch (security)2.3.3-1+deb9u11fixed
ruby2.5 (PTS)buster, buster (security)2.5.5-3+deb10u4fixed
ruby2.7 (PTS)bullseye (security), bullseye2.7.4-1+deb11u1fixed
sid2.7.5-1fixed
ruby3.0 (PTS)bookworm, sid3.0.4-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby2.3sourcestretch2.3.3-1+deb9u11DLA-2853-1
ruby2.3source(unstable)(unfixed)
ruby2.5sourcebuster2.5.5-3+deb10u4DSA-5066-1
ruby2.5source(unstable)(unfixed)
ruby2.7sourcebullseye2.7.4-1+deb11u1DSA-5067-1
ruby2.7source(unstable)2.7.5-1
ruby3.0source(unstable)3.0.3-11002995

Notes

Fixed in Ruby 3.0.3, 2.7.5, 2.6.9
https://www.ruby-lang.org/en/news/2021/11/24/cookie-prefix-spoofing-in-cgi-cookie-parse-cve-2021-41819/
Fixed by: https://github.com/ruby/cgi/commit/052eb3a828b0f99bca39cfd800f6c2b91307dbd5 (v0.3.1)

Search for package or bug name: Reporting problems