CVE-2021-41990

NameCVE-2021-41990
DescriptionThe gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4989-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)stretch5.5.1-4+deb9u4fixed
stretch (security)5.5.1-4+deb9u5fixed
buster5.7.2-1vulnerable
buster (security)5.7.2-1+deb10u1fixed
bullseye5.9.1-1vulnerable
bullseye (security)5.9.1-1+deb11u1fixed
bookworm, sid5.9.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansourcestretch(not affected)
strongswansourcebuster5.7.2-1+deb10u1DSA-4989-1
strongswansourcebullseye5.9.1-1+deb11u1DSA-4989-1
strongswansource(unstable)5.9.4-1

Notes

[stretch] - strongswan <not-affected> (The vulnerable code was introduced later in version 5.6.1)
https://www.strongswan.org/blog/2021/10/18/strongswan-vulnerability-(cve-2021-41990).html

Search for package or bug name: Reporting problems