CVE-2021-42006

NameCVE-2021-42006
DescriptionAn out-of-bounds access in GffLine::GffLine in gff.cpp in GCLib 0.12.7 allows an attacker to cause a segmentation fault or possibly have unspecified other impact via a crafted GFF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs996591

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgclib (PTS)bookworm, bullseye0.11.10+ds-2vulnerable
sid0.12.7+ds-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgclibsource(unstable)(unfixed)996591

Notes

https://github.com/gpertea/gclib/issues/11

Search for package or bug name: Reporting problems