CVE-2021-42013

NameCVE-2021-42013
DescriptionIt was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)stretch2.4.25-3+deb9u9fixed
stretch (security)2.4.25-3+deb9u11fixed
buster2.4.38-3+deb10u5fixed
buster (security)2.4.38-3+deb10u6fixed
bullseye2.4.48-3.1+deb11u1fixed
bullseye (security)2.4.51-1~deb11u1fixed
bookworm, sid2.4.51-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcestretch(not affected)
apache2sourcebuster(not affected)
apache2sourcebullseye(not affected)
apache2source(unstable)2.4.51-1

Notes

[bullseye] - apache2 <not-affected> (Vulnerable code not present, only affects 2.4.49/2.4.50)
[buster] - apache2 <not-affected> (Vulnerable code not present, only affects 2.4.49/2.4.50)
[stretch] - apache2 <not-affected> (Vulnerable code not present, only affects 2.4.49/2.4.50)
https://www.openwall.com/lists/oss-security/2021/10/07/6
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2021-42013
https://www.openwall.com/lists/oss-security/2021/10/08/1

Search for package or bug name: Reporting problems