CVE-2021-42374

NameCVE-2021-42374
DescriptionAn out-of-bounds heap read in Busybox's unlzma applet leads to information leak and denial of service when crafted LZMA-compressed input is decompressed. This can be triggered by any applet/format that
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs999567

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
busybox (PTS)stretch1:1.22.0-19fixed
stretch (security)1:1.22.0-19+deb9u2fixed
buster1:1.30.1-4vulnerable
bullseye1:1.30.1-6vulnerable
bookworm, sid1:1.30.1-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
busyboxsourcestretch(not affected)
busyboxsource(unstable)(unfixed)unimportant999567

Notes

[stretch] - busybox <not-affected> (Vulnerable code introduced later)
https://jfrog.com/blog/unboxing-busybox-14-new-vulnerabilities-uncovered-by-claroty-and-jfrog/
Crash in CLI tool with information leak
Introduced by https://git.busybox.net/busybox/commit/?id=3989e5adf454a3ab98412b249c2c9bd2a3175ae0 (1_27_0)
https://git.busybox.net/busybox/commit/?id=04f052c56ded5ab6a904e3a264a73dc0412b2e78

Search for package or bug name: Reporting problems