CVE-2021-42522

NameCVE-2021-42522
DescriptionThere is a Information Disclosure vulnerability in anjuta/plugins/document-manager/anjuta-bookmarks.c. This issue was caused by the incorrect use of libxml2 API. The vendor forgot to call 'g_free()' to release the return value of 'xmlGetProp()'.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
anjuta (PTS)buster2:3.28.0-5vulnerable
bullseye2:3.34.0-3vulnerable
bookworm, sid2:3.34.0-8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
anjutasource(unstable)(unfixed)unimportant

Notes

https://gitlab.gnome.org/Archive/anjuta/-/issues/12
Memory leak in GUI application, no security impact

Search for package or bug name: Reporting problems