CVE-2021-42528

NameCVE-2021-42528
DescriptionXMP Toolkit 2021.07 (and earlier) is affected by a Null pointer dereference vulnerability when parsing a specially crafted file. An unauthenticated attacker could leverage this vulnerability to achieve an application denial-of-service in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3585-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exempi (PTS)buster2.5.0-2vulnerable
buster (security)2.5.0-2+deb10u1fixed
bullseye2.5.2-1vulnerable
bookworm2.6.3-1fixed
trixie, sid2.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exempisourcebuster2.5.0-2+deb10u1DLA-3585-1
exempisource(unstable)2.6.0-1

Notes

[bullseye] - exempi <no-dsa> (Minor issue)
https://helpx.adobe.com/security/products/xmpcore/apsb21-108.html
https://github.com/adobe/XMP-Toolkit-SDK/commit/16e53564ae6c2689387479c04770f492075d5b7b (v2021.08)
https://cgit.freedesktop.org/exempi/commit/?h=adobe-sdk&id=16e53564ae6c2689387479c04770f492075d5b7b (2.6.0)

Search for package or bug name: Reporting problems