CVE-2021-42530

NameCVE-2021-42530
DescriptionXMP Toolkit SDK version 2021.07 (and earlier) is affected by a stack-based buffer overflow vulnerability potentially resulting in arbitrary code execution in the context of the current user. Exploitation requires user interaction in that a victim must open a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3585-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exempi (PTS)buster2.5.0-2vulnerable
buster (security)2.5.0-2+deb10u1fixed
bullseye2.5.2-1vulnerable
bookworm2.6.3-1fixed
trixie, sid2.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exempisourcebuster2.5.0-2+deb10u1DLA-3585-1
exempisource(unstable)2.6.0-1

Notes

[bullseye] - exempi <no-dsa> (Minor issue)
https://helpx.adobe.com/security/products/xmpcore/apsb21-108.html
https://cgit.freedesktop.org/exempi/commit/?h=2.6.0&id=77a3fe7096f8ebf301e2bfe1e6dc023b4ff6dc48

Search for package or bug name: Reporting problems