CVE-2021-42771

NameCVE-2021-42771
DescriptionBabel.Locale in Babel before 2.9.1 allows attackers to load arbitrary locale .dat files (containing serialized Python objects) via directory traversal, leading to code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2790-1
NVD severityhigh
Debian Bugs987824

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-babel (PTS)stretch2.3.4+dfsg.1-2vulnerable
stretch (security)2.3.4+dfsg.1-2+deb9u1fixed
buster2.6.0+dfsg.1-1vulnerable
bookworm, sid, bullseye2.8.0+dfsg.1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-babelsourcestretch2.3.4+dfsg.1-2+deb9u1DLA-2790-1
python-babelsource(unstable)2.8.0+dfsg.1-7987824

Notes

https://www.tenable.com/security/research/tra-2021-14
https://github.com/python-babel/babel/pull/782

Search for package or bug name: Reporting problems