CVE-2021-43177

NameCVE-2021-43177
DescriptionAs a result of an incomplete fix for CVE-2015-7225, in versions of devise-two-factor prior to 4.0.2 it is possible to reuse a One-Time-Password (OTP) for one (and only one) immediately trailing interval. CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1009636

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-devise-two-factor (PTS)stretch3.0.0-2vulnerable
bullseye3.1.0-2vulnerable
bookworm, sid4.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-devise-two-factorsource(unstable)4.0.2-11009636

Notes

https://github.com/tinfoil/devise-two-factor/security/advisories/GHSA-jm35-h8q2-73mp
https://github.com/tinfoil/devise-two-factor/pull/108
https://github.com/tinfoil/devise-two-factor/commit/64576bb9e7d29800c5f92bb86fb6ecff91ad6105 (v4.0.2)

Search for package or bug name: Reporting problems