CVE-2021-43331

NameCVE-2021-43331
DescriptionIn GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can execute arbitrary JavaScript for XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs1000367

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mailman (PTS)stretch1:2.1.23-1+deb9u5vulnerable
stretch (security)1:2.1.23-1+deb9u7vulnerable
buster1:2.1.29-1+deb10u1vulnerable
buster (security)1:2.1.29-1+deb10u2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mailmansource(unstable)(unfixed)1000367

Notes

[buster] - mailman <no-dsa> (Minor issue)
[stretch] - mailman <no-dsa> (Minor issue)
https://mail.python.org/archives/list/mailman-announce@python.org/message/I2X7PSFXIEPLM3UMKZMGOEO3UFYETGRL/
https://bugs.launchpad.net/mailman/+bug/1949401

Search for package or bug name: Reporting problems