CVE-2021-43518

NameCVE-2021-43518
DescriptionTeeworlds up to and including 0.7.5 is vulnerable to Buffer Overflow. A map parser does not validate m_Channels value coming from a map file, leading to a buffer overflow. A malicious server may offer a specially crafted map that will overwrite client's stack causing denial of service or code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1009070

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
teeworlds (PTS)buster, buster (security)0.7.2-5+deb10u1vulnerable
bookworm, sid, bullseye0.7.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
teeworldssource(unstable)(unfixed)1009070

Notes

[bullseye] - teeworlds <no-dsa> (Minor issue)
[buster] - teeworlds <no-dsa> (Minor issue)
https://github.com/teeworlds/teeworlds/issues/2981
https://github.com/teeworlds/teeworlds/pull/3018
https://github.com/teeworlds/teeworlds/commit/91e5492d4c210f82f1ca6b43a73417fef5463368
https://mmmds.pl/fuzzing-map-parser-part-1-teeworlds/

Search for package or bug name: Reporting problems