CVE-2021-43529

NameCVE-2021-43529
DescriptionThunderbird versions prior to 91.3.0 are vulnerable to the heap overflow described in CVE-2021-43527 when processing S/MIME messages. Thunderbird versions 91.3.0 and later will not call the vulnerable code when processing S/MIME messages that contain certificates with DER-encoded DSA or RSA-PSS signatures.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2874-1, DSA-5034-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.12.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.12.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.12.0-1~deb12u1fixed
trixie1:115.11.0-1fixed
sid1:115.12.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
thunderbirdsourcestretch1:91.4.1-1~deb9u1DLA-2874-1
thunderbirdsourcebuster1:91.4.1-1~deb10u1DSA-5034-1
thunderbirdsourcebullseye1:91.4.1-1~deb11u1DSA-5034-1
thunderbirdsource(unstable)1:91.3.0-1

Notes

https://www.openwall.com/lists/oss-security/2021/12/01/6
https://bugzilla.mozilla.org/show_bug.cgi?id=1738501

Search for package or bug name: Reporting problems